V Forum

[ log in ]

No exe after compiling

sq16 Dec 25 15:49
Hi. Just started with V.

I have W10 1909 + GCC.

When I compile the "tetris.v" example V shows nothing and I cannot find an exe file.

When doing a global search I find the directory: "C:\Users\Public\Documents\Wondershare\CreatorTemp\v"
containing these files: a.out.tmp.c, tetris.exe.tmp.c, tet
ris.tmp.c and vrepl.tmp.c all with the timestamp of compilation time. But no exe file.

So, why using such weird folder for (temp) files?

Also, when I use the -o option, no exe.

Any insights?
sq16 Dec 25 20:27
Found why "C:\Users\Public\Documents\Wondershare\CreatorTemp\v" is used. Happens to be envvar TMPDIR..

Still no exe generated anywhere ...
kpeters58 Dec 26 03:00
Does compiling with the stats flag give any clues? Or any of the the debu/troubleshooting options?

As per 'v help'
sq16 Dec 26 09:46
Nope. Total silence!
sq16 Dec 26 09:47
Even "v -v" doesn't show anything!!!
kpeters58 Dec 26 17:01
I believe this happened to me as well some time ago - I recall doing full searches for the exe I believed had been built. Never found anything. I then erased my v install and cloned fresh and - voila - everything worked as expected and does so to this day
spytheman Dec 27 07:58
Try compiling with `v -show_c_cmd -keep_c -verbose tetris.v` . It should produce more output for you to see what is going on.
spytheman Dec 27 08:00
-stats is honored only when running tests
spytheman Dec 27 08:02
We have to document -verbose in `v help` ... Previously it was not documented, because it was too verbose, and showed internal compiler info (language tokens and so on), but now it is very useful for debugging these kinds of problems.
spytheman Dec 27 08:09
https://github.com/vlang/v/pull/3250 - done.



Powered by Vorum, open-source blogging/forum software written in V